PDA

View Full Version : Connection Lost for Windows XP



cavench
04-24-2014, 09:41 AM
Your Display Name: cavench
Bug Description: Connection Lost followed by client freeze in Windows XP
Steps to Reproduce: Log in Beta Client. Connection lost occurs automatically after several minutes. Possible 5 minute time out.
Frequency: Every client session.
Additional Information: see Alpha thread http://forums.cryptozoic.com/showthread.php?t=34567

Edit: to add the above template. OP is below.

It appeared this is happening for the Beta Client as well. It could be the 5 minutes time out, but at the time I was going through my cards manager and I thought I was fairly active with the mouse clicks. Whether or not if it is 5 minutes time out, this problem will cause me not to participate my free drafts. Since I wouldn't be able to rejoin the draft after the connection lost.

One thing is different than the Alpha Client. In Alpha, after closing the "Connection Lost" window, the client does not kick me out (although I am indeed offline). In Beta, the client freezes when I try to close the message window.

Btw, my internet connection has been stable throughout this experience.

Xenavire
04-24-2014, 09:47 AM
When did this happen to you? Because all the servers had to be taken down for maintenance and haven't gone up yet, and it is likely related.`

cavench
04-24-2014, 11:50 AM
It happened around 9:30pm PDT last night. I spent about an hour last night redeeming my kickstarter codes and going over my cards, within this hour I experienced 5 Connection Losts (and then the immediate client freeze). I was able to re-open the client and reconnect each time. So it was before the maintenance.

Xenavire
04-24-2014, 11:59 AM
It happened around 9:30pm PDT last night. I spent about an hour last night redeeming my kickstarter codes and going over my cards, within this hour I experienced 5 Connection Losts (and then the immediate client freeze). I was able to re-open the client and reconnect each time. So it was before the maintenance.

That was about the time the server instability was getting bad. I have no idea what happened to everyone else, but there is a good chance your problems will be resolved today. If they persist, keep this thread updated and open a support ticket.

cavench
04-26-2014, 05:11 PM
Patches over the last couple days did not fix this problem. I was disconnected while building a deck in card manager. Although there was plenty of mouse clicks (on/off filter options and moving cards around); it is likely that these mouse commands are just client-side and no data was sent to server. So this still could be a 5 minute time-out.

My main concern is with this bug it is unlikely I can finish a tournament. This wouldn't be an issue if not for the free drafts have expiration dates.

Anyone else with Windows XP also have connection lost issues?

Ceiphied
04-26-2014, 09:22 PM
I have been having/following this problem since alpha started, and yes it does seem like its a XP problem. As of the beta it has not changed. For the moment cavench here is what i have been doing as a work around until it gets fixed.

In the card manager or when building decks in draft or sealed just remember to save the deck before the 5 min are up and keep doing it if waiting for tournament to start. If in a queue for a tournament just drop and re-enter before time is up (5 min). Lastly when waiting in a tournament lobby for the next round to start, make sure to go to the reserves and save before time is up (5 min).

Not the most fun but finishing tournaments is doable. Just make sure to send a server side ping while your on. I've been dropped out of a few events during alpha when I mistime it but a good timer helps.

Volycifer
04-26-2014, 10:14 PM
I have XP and have this problem also. The connection always times out after a few minutes in deck builder. It's gotten no better since alpha. Truly annoying. Starting to wish I could get my money back.

f5shooter
04-27-2014, 06:54 AM
Exact same problem here. I'm also on XP. I mentioned it numerous times during the Alpha as well.

dwebber88
04-27-2014, 07:11 AM
I have linked this thread into the critical bugs, in the consolidated list for bugs that need to be fixed asap.

Disordia
04-29-2014, 07:06 AM
I would suggest upgrading your OS. I doubt they will do anything about XP issues since its already past its end of life date.

cavench
04-29-2014, 10:14 AM
According to Beta email the beta client supports PC (Windows XP/Vista/7/8).

I'm waiting for more news on Windows 9 before deciding which OS upgrade for my family. I'm holding tight until mid-2015 and until then I hope Hextcg won't be the reason for me to upgrade OS immediately.

Disordia
04-29-2014, 10:27 AM
Hmm that's surprising, but I still would suggest updating your OS immediately.

AdamAoE2
05-24-2014, 03:15 PM
This bug still happens to my buddy who is running Windows XP. Hope theres resolution soon. :-)

Ceiphied
06-04-2014, 10:26 PM
While the timeout problem is very annoying there are workarounds, but with the latest patch removing the reserves button from the tournament lobby between rounds I'm stuck in the lobby hoping the next round starts before 5 minutes are up or I can relaunch and login before the next round starts.

So could you either bring back the reserves button until the connection lost problem is fixed or add something else to ping the servers so those of us with this problem can attempt to stay connected while drafting.

carontestyx
06-26-2014, 10:46 AM
Same problem here, also in XP. I know Windows XP is way past beyond its life span, but if the beta mail said the client supports XP (as a previous poster in this thread said) then I think this problem should be fixed. And if not, well, then at least give us an official "update your OS, buddy". Please. Pretty please.

DionyzRex
06-26-2014, 11:02 AM
We're looking into this, thanks for the report.