PDA

View Full Version : Mana Used, but Card was not played



TheSwallowsNest
08-28-2014, 08:06 PM
I encountered a strange bug today.

I had 6 mana and wanted to play my ambershire instigator in my 2nd main phase, after I attacked.

I attacked my opponent and he blocked with his axe bot, which was killed.

I tend to play somewhat faster than most people and quickly passed priority after damage was dealt without really thinking about the axe bot.


The strange thing is the axe bot (where it buffs another troop) resolved right after my second main phase began. I had clicked my ambershire card quickly and as soon as I did, the axe bot resolution appeared on the chain.

When it resolved, I noticed that I had only 1 mana left, I had not until that point played any cards other than attempting to play my ambershire which was pre-empted by the axe bot resolution.

This was not some sort of visual bug where the card was really in the field but for some reason still displayed in my hand. I ended up playing the ambershire the next turn.

Xexist
08-28-2014, 09:39 PM
What is this mana you speak of

Yoss
09-03-2014, 02:22 PM
There are a few bad things that can happen if you don't wait for a full transition from combat to MP2 before doing things. Add this one to the list.

MythicFishmom
09-04-2014, 05:01 AM
This bug has happened to me before too. Some of these enter graveyard abilities like axe bot or inquisitor are slower than your typical abilities. If you play something before these abilities resolve you will not be able to play anything. The way to avoid this is to be patient and wait until you see the ability resolve then play whatever you need from your hand.

noragar
09-04-2014, 07:25 AM
I had the same thing happen last night, with a little twist.

I made a normal attack which hit, no Axe Bots or anything on the chain, then in my second main phase I tried to play a Turreted Wall. It didn't seem like it at the time, but I was actively trying to conserve time on the clock, so I may have been a little quick in trying to play it. My Resources dropped from 5/5 to 1/5, but the Wall remained in my hand.

The next turn, I dropped a resource and to make sure I got it out, tried to play the Wall in my first main phase. It went into play, but my resources dropped from 6/6 to 0/6, so it cost 6 instead of costing 4.

So the reason for posting is to include that little added piece of info about the cost increase, which may or may not be relevant.

mightygerm
09-04-2014, 08:49 AM
I have also had this happen before, but I'm not able to reproduce it.