PDA

View Full Version : Champion power bugged in VIP tournament



DanTheMeek
09-26-2014, 01:54 PM
Display Name: TheMeek

Bug Description: In the 10 AM PST VIP tournament this morning I was in the finals, I'd saved up my champion power as I was running the bunny champ who makes bunnies and was facing a deck I suspected (correctly) was using extinction. Finally the moment to put the pedal to the metal and go all in made itself available to me based on his actions during combat, so sitting on 6 charges I went to use my power during main phase 2.... and it wouldn't work. For some reason it was no longer glowing and click-able.

I asked my opponent just to make sure I wasn't losing my mind and he agreed that as far as he knew you were supposed to be able to use champion powers during main phase 2, no idea why I couldn't do so. I took a screen shot if that's necessary at all, but basically I was forced to not do anything, wasting a huge opportunity. Next turn I could use the power again, but obviously only once per turn (as IS my understanding of how it was supposed to work) and since the bunny couldn't attack that turn I'd lost tempo and ultimately lost the match.

I'd be lying if I claimed I felt this would have swung the match in my favor, I had a bad match up in general and my opponent drew well and played perfect, but was still frustrating and I have no idea what caused my loss of champion power.

ossuary
09-26-2014, 02:43 PM
I can confirm that you should have been able to use your charge power during main phase 2, I do it all the time. Definitely a bug/glitch of some sort.

N3rd4Christ
09-26-2014, 02:51 PM
Threshold?

Xenavire
09-26-2014, 02:58 PM
He said it 'stopped flashing' (paraphrasing) which can only mean it was active before. I have run into this issue myself on rare occasions, but only against the AI - I thought it was an AI issue that would be fixed with the new AI, turns out I was wrong and should have reported it. :p

ossuary
09-26-2014, 04:13 PM
I have seen it once or maybe twice over the course of all of alpha and beta, but I was never able to reproduce it. Also, the only times I ever saw it were when we were still having the synching issues with the server, so I just assumed it was an out of synch problem where your client thought you played it but the server never got the message, so it got "used up" without actually activating.

I guess it's still a really rare glitch somewhere in the system.

Xenavire
09-26-2014, 04:15 PM
I have seen it once or maybe twice over the course of all of alpha and beta, but I was never able to reproduce it. Also, the only times I ever saw it were when we were still having the synching issues with the server, so I just assumed it was an out of synch problem where your client thought you played it but the server never got the message, so it got "used up" without actually activating.

I guess it's still a really rare glitch somewhere in the system.

Actually, there were some server issues today, so its possible it might have been a synch issue? Could be a valid explanation.

Zurai
09-26-2014, 08:00 PM
Had you already used it once that turn? Champion charge powers can only be used once per turn. Just a thought.

ossuary
09-26-2014, 08:04 PM
He already said he hadn't. And his opponent agreed with him about it being bugged. I doubt two experienced players would miss the fact that he'd already used it. :)