View Full Version : Which Equipment actually work?

02-05-2015, 07:22 PM
Perhaps we can compile a list of equipment that actually works? I've tested over a dozen so far and none had any effect whatsoever (and I wasn't using alternate art cards).

02-05-2015, 08:54 PM
That'd have been a good start of a list. =/

02-05-2015, 08:58 PM
I'll happily start adding to this list when I get a chance to play arena tonight. Will probably edit into this very post. I hope others care to do the same.

Headband of Inquisition - Xentoth's Inquisitor
Redefinable Adaptable Cuirass Device - S.P.A.M Bot
Ascension Treads - Guardian Angel

Not Sure:
The Mirrorblade - Replicators Gambit

Not Working:

02-05-2015, 10:57 PM
Working Equipment :

Time ripple javelin (weapon slot) - Cards bounced always get cost +2... 5 times tested
Phoenix Guard Messenger (Glove slot) - Messenger successfully reduced to 1 every match
Eldritch Dreamer (Helmet slot) - Successfully doubles the gem effect (Works with draw card gem but no with create a rhino gem)

Non Working Equipment :

Lixil's Trinket : 2 cost exhaust to give a troop a random gem buff
Genesis Pool Naiad : (Feet slot) - does not gain +1 defense

Sorry for forgetting the names of the equipment, I will update post with equipment names when i log back in later

02-06-2015, 12:52 AM
Gardener's Hat [Chlorophyillias cost -1]

Does not work:
Primal Dagger [Eye of Creation troops put into play have permanent speed]
Locket of the Elven Court [Eye of creations have "gain X health"
Midsummer Cloak [When Puck enters play reveal top 5 cards and put those with cost >=5 into your hand] —> tested direct into play and via an Eye of Creation both do not work.
Dawnsword [Angel of Dawn - if you have >=5 permanent resources the next non resource card costs 0]
Divinity's light [Angel of Dawn]
Aegis of Oblivion [Dishonourable Death - void all copies of that card in all zones]

02-06-2015, 01:14 AM
Does not work:
Patience [You pay 3 less to play King Gabriel] {Princess Victoria} It did not make His Majesty, King Gabriel, 3 cheaper (which almost cost me the game yesterday, gonna have to start working on a decent deck).

(this was tested with the original art card, didn't draw the alternate art)

02-06-2015, 01:15 AM
Burn equipment that makes it deal 3 damage works.

02-06-2015, 01:20 AM
Are you guys also reporting these in the bug report forum? I know I have seen the Eye of Creation bug reported, but not sure on the others.

02-06-2015, 04:25 AM
Stink Boots [Stink Troll], Dandelion Arm Guards [Crackling Sprout] both work, Gladiator Helm [Arena Regular] does not.

02-06-2015, 05:05 AM
Good Ol' Boulder [Boulder Toss] does not work as well

02-06-2015, 05:44 AM
Darkspire Longblade (Darkspire Priestess)
Accursed Jerkin (Darkspire Punisher)
Shadow Gloves (Darkspire Tyrant)
Hood of the Darkspire (Darkspire Tyrant)
Sigil of the Bleeding Cut (Throat Cutter) - this one is fun!

Does Not Work:
Mask of the Steel Assassin (Murder): adds text to card, but effect does not trigger
Grips of the End (Extinction): does not add text, effect does not trigger
Spell Kickers (Inquisition): does not add text, effect does not trigger

02-06-2015, 06:05 AM
shinhare eulogist: robes of sublime sacrifice (chest)works <--- defiantly gonna be one of my fav bunny equips
shinhare eulogist: necklace of many deaths (necklace) doesn't (as far as my testing could show, killed crush troop with eulogists at like 13 attack, was hoping for clear test with working evolve equip, but 3 tries on that show is definatly not working for adding keywords)
evolve: boots of change (boots) doesn't
hop'hiro: samurai kabuto (helmet) doesn't
blood bearer: porter's gauntlets (gloves) doesn't

will edit in other bunny equips i get to test

02-06-2015, 06:10 AM
I'll amend http://imgur.com/a/xOwIR when arena is on LIVE with bugs people find so it can be seen easier.

02-06-2015, 07:06 AM
I will edit my post if I find more, but here are the couple i have currently discovered to either work or not work.

Xentoth's Inquisitor

Headband of Inquisition - Works
Siphoning Boots - Does not Work

Oracle Song

Song of the Ancestors - Works


Sacred Scythe - Does not Work


Bramblebriar Helm - Works

Wrathwood Mastermoss

Bramble Boots - Works

Plant Garden

Nightshade Medallion - Does not Work

02-06-2015, 09:54 AM
Mirror Blade, Sleight of Hands for Replicators Gambit do not work.

I forget the names of them, but the equipment for Royal Falconer doesn't work.

Someone in chat said that the equipment that makes Rune Ear Commander add a battlehopper per turn to the field was working, but I haven't confirmed it myself yet.

Edited to say Ceremonial Guard does reduce the cost of Mentor of Oakhenge's Oakhenge ceremony upon death.

Also Pack Raptors "The Calling Blade" and "Raptor Boots" do not work.

02-06-2015, 11:39 AM
Gearsmith's equipment to let you search the top 5 cards does not work.

Reese's equipment to fill your hand up to 7 cards with random robots when he comes into play does not work.

War Machinist's equipment to deal his damage to all opposing troops as well DOES work (which is insane!).

02-06-2015, 12:26 PM
Scheme's equipment (Weapon, Conniving Switchblade) doesn't seem to work.

02-06-2015, 12:37 PM
Crackling Sprout

Not Working:
Both Argus Equip
Both Scraptech Brawler Equip
Both Reese Crustcrawler Equip
Crackling Bolt
Goremaster Trinket

02-06-2015, 01:00 PM
Tower Hulk's equipment to give it Steadfast does not work either.

02-06-2015, 01:23 PM
Gront the Infinite: Dome of Extraction- Only opposing troops get -1atk/-1def
Maniacal Entreprenuer: Lunatic Kickers- Whenever you play a goblin this gets +1atk

Not Working:
Izydor: Crusading Clutches- Whenever a goblin enters play revert Izydor
Goblin Cooking Pot: Goblin Bomber Jacker- Target troop gets -1atk/-1def
Relentless Corruption: Harbringer of Pestilence- Stolen card card gets -1 cost

02-06-2015, 01:27 PM
IGN: Raistlin

Bloodsucker Helm - Giant Mosquito
Accursed Jerkin - Darkspire Punisher
Darkspire Longblade - Darkspire Priestess

Not Working:
Blackblade - Paladin of Necropolis
Gloves of the Dark Side - Terrible Transfer
Gloves of the unrelenting pain - Corpse Fly
Head of the Forgotten - Kog'tepetl's Thirst
Spellblood Crown - Vampire King (also this is a trinket, surely it should be head gear)
The Night Cane - Vampire King

02-06-2015, 01:27 PM
- Unstable Induction Rapier [Inductocopter]
- Bog Walkers [Highland’s Magus]
- Thunderstrike Chestguard [Thunderbird]
- Benjamin’s Orb [Crackling Wit]

Not Working:
- Gauntlets of Multiplicity [Cerulean Mirror Knight]

02-06-2015, 01:38 PM
Mushwocky equipment not working, I tried the gear for Crackling Wit and I am 90% sure it was working but don't string me up if I was mistaken.

02-06-2015, 03:01 PM
Not Working:
Ingenious Engineer (Both - Gloves work, but freeze game, and not working as intended - weapon doesn't work at all)
Eurig the robomancer
Bottled Vitae
Elite Battle tech

02-06-2015, 03:26 PM
not working: jika-tabi of destiny (killblades of the milky eye)

02-06-2015, 08:22 PM
not working

both pieces of Protectorate Clergyman gear
shrine of prosperity - tiara of abundance
solitary exile weapon - lonely axe half works...does not give you a choice of taking card back to hand,does it auto and when troop came back into play was visually exhausted(was still ready but in the exhaused position)

adamanth scrivener's gloves

02-07-2015, 08:30 AM
- Sultry Shell [Heat Wave]
- Conflagration Handguards
- Helm of the Spawn [Crackling Rot]
- Autumn Leaf [Constantina]
- Vest of the Ruminant [Dream Stag]
- Musky Leather Gloves [Dream Stag]
- Mossling Dandelion [Wrathwood Master Moss]
- Ballroom Slippers [Queen Grace]
- Battleborn Breastplate [Prince Talysen]

[b]Not Working:
- Faith’s Grasp [Spearcliff Cloud Knight]
- Globe of Nightmares [Inner Conflict]
- Orb of Harmony [Genesis Naiad, both versions]
- Prosperous Tunic [Shrine of Prosperity]
- Mage Hands [Eldon’s Distress Signal]
- Oblivion’s Call [Infernal Professor]
- Feet of the Unending Plague [Relentless Corruption]
- Staff of the Conflagration [Ragefire]
- Hood of Breezes [Windbourne Acolyte AA]
- The Storm Fan [Cloudgazer]
- Sous Chef Slippers [Shiitake Chef]
- Feral Boots [Crash of Beasts]
- Cottontail Jitte [Cottontail Ronin]
- Helm of the Monarchy [Queensguard]
- Highland Embersoul [Prince Talysen]
- Belt of the Legion [Hero of Adamanth]

02-07-2015, 12:07 PM
Someone might have already said this but a good guide line to know if something actually works is to check the card in your deck manager after putting on the equipment. If you can see the visual change to the text on the card chances are it works and vise versa. I'm not sure if this is 100% or not but it has worked for me so far. Anyways hope that helps.

02-07-2015, 12:19 PM
Someone might have already said this but a good guide line to know if something actually works is to check the card in your deck manager after putting on the equipment. If you can see the visual change to the text on the card chances are it works and vise versa. I'm not sure if this is 100% or not but it has worked for me so far. Anyways hope that helps.

Ive noticed this to mostly be the case but a few other pieces still work as well

02-08-2015, 11:13 AM
Does not work :

- Sliver of the Immortal Spear (Head)
- Menacing Gralk (Weapon)
- Yesterday (Trinket)

Might not work :

-Sliver of the Immortal Spear (Feet) (5% chance to proc, never proced in around 50 tries)