Results 1 to 5 of 5

Thread: Loading Data Screen

  1. #1

    Loading Data Screen

    Anyone else getting stuck at the "Loading Data" Screen? The loading bar filled very slowly but now that it has finished, it is still at this screen and has not moved to the main menu. One more thing, it still says "Alpha" on this screen.

  2. #2
    then you dont have the right client. you have to download the beta client.
    King Tier Backer

  3. #3
    I'm pretty sure I do have the right client, it says "Closed Beta" and then when I press the "Play Now" button it takes me a login screen that says "Alpha".

  4. #4
    Quote Originally Posted by Toberman View Post
    I'm pretty sure I do have the right client, it says "Closed Beta" and then when I press the "Play Now" button it takes me a login screen that says "Alpha".
    Then you dont have the right client. My alpha client says Alpha, my beta client says Beta. i can run them both on the same time even.

    Edit: As for it says "Closed Beta", yea in the text maybe but not the logo, right?
    King Tier Backer

  5. #5
    Quote Originally Posted by Toberman View Post
    I'm pretty sure I do have the right client, it says "Closed Beta" and then when I press the "Play Now" button it takes me a login screen that says "Alpha".
    You might need to delete the old client completely, then reinstall with this: dl.hex.gameforge.com/HEXSetup.exe

    Or for macs: dl.hex.gameforge.com/HexInstaller.dmg
    Xenavire, proud guild leader for The Lions Share.
    http://i307.photobucket.com/albums/n...erlinsmall.png

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •