View Full Version : Princess Victoria in starting hand

05-13-2014, 10:29 PM
I had a Princess Victoria in my starting hand (first game after downloading the patch), but her cost stayed at 3 instead of being reduced to zero.

05-13-2014, 10:37 PM
Second game I played, I drew Princess Victoria after a mulligan, and it worked correctly. Third game I drew two in my first hand and they both worked correctly. Both times it worked correctly I went first, but when it failed I drew first. So that may be the issue.

Edit: Nope, when the opponent went first it still worked correctly. It's only failed to work one time for me, so I'm not sure how to reproduce it.

05-14-2014, 04:01 AM
Random question, probably not related, but are you counting your first draw if you play second, as being in the starting hand? Because I have seen lots of these reports, but I have not seen the bug myself, and it just occured to me that starting hand does seem vague to some people.

05-14-2014, 04:26 AM
I've seen Victoria fail to trigger about 10% of the time. No obvious consistency - it's been as a straight starting hand, after a mulligan, when there were 2 in hand. Sometimes she just doesn't do that little shake to make 3 cost fall off.

05-14-2014, 01:48 PM
Have you tried playing her to see if it's just a display issue?

05-14-2014, 04:17 PM
I did some testing. I just started up about 30-35 games against the AI using a Human deck with 4 copies of Princess Victoria in. Number of cards is cards in starting hand I had to mulligan to to get at least one PV in hand.

Victoria Zeroed Correctly
7 cards, 1 Victoria: 3
7 cards, 2 Victoria: 3
6 cards, 1 Victoria: 4
6 cards, 2 Victoria: 2
5 cards, 1 Victoria: 3
3 cards, 1 Victoria: 1
Total: 16

Victoria stayed at Cost 3 and could not played for 0 after putting down Diamond threshold
7 cards, 2 Victoria: 1
6 cards, 1 Victoria: 1
3 cards, 1 Victoria: 1
2 cards, 1 Victoria: 1
Total: 4

And a bunch of attempts where I couldn't get a single Victoria in my starting hand.
And two games that hung after mulligans and before my turn started.

So for this statistically insignificant sample it looks to still be bugged around 20% of the time.

05-26-2014, 10:53 AM
I've played many, many more games with Victoria and still haven't reproduced the bug myself. Has anyone encountered this recently?

05-26-2014, 12:35 PM
I noticed it again a few days ago - Saturday, I guess it was?

05-26-2014, 03:31 PM
Okay, I guess I'm just getting lucky. =)

06-14-2014, 04:25 PM
I can confirm I just had this bug happen to me yesterday (june 13th). I was going 2nd, no mulligans and she stayed at 3.

06-14-2014, 06:13 PM
When this finally happened to me again a couple weeks ago (May 31), I took a screenshot of the full cost Victoria in my opening hand. Looking at the screenshot later, I noticed that although I was going first, I had 8 cards in hand... so my suspicion is that this bug occurs when some other bug occurs where the first player draws a card?

06-16-2014, 11:31 AM
Care to share your screenshot?

We are still trying to track this bug down.
It's not consistent, so any data we can get on it is useful.
I have seen the bug happen personally, but couldn't get it to happen twice.

Also, does anyone that had the bug happen know if your opponent might have had a Victoria of their own?

06-16-2014, 12:23 PM
All my tests were vs. the AI, so definitely no chance they had a Victoria of their own.

06-16-2014, 11:37 PM
Whenever I try to upload the screenshot, it fails to upload. Is there a size limit?

Info you might want to know about it:

Opponent: Poca
Opponent's number of cards: 7
Opponent did not mulligan (local chat is visible with no mulligan message) and has no cards or resources in play or in the discard pile, so no chance that opponent actually went first this game, unless he also didn't play a resource and didn't think not having a resource was a cause to mulligan (and I somehow didn't notice that my opponent went first and did nothing).

My champion: Wyatt (last time the bug happened to me it was Dimmid)
Cards in my hand (8!): 3 Ruby shards, 1 Sapphire shard, Ragefire, Ascetic Aspirant, Princess Victoria, Lord Benjamin
It's the first main phase, and Victoria has a cost of 3. Obviously, the screenshot can't confirm that Vic wasn't the card I drew, but even if I somehow mis-remembered that, I shouldn't be drawing on the first turn of the game... so unless my opponent did nothing, and I didn't notice and didn't have the opportunity to pass priority (or had it but forgot about taking the screenshot until it was my turn), there's another bug going on here...